DBAToolZ

Lightweight Oracle DBA Tools

 

11gR2 install fails with “Hard Limit: maximum user processes” error

Just finished dealing with “Hard Limit: maximum user processes” error on Open Solaris 10 while installing 11gR2:

11gR2 install fails with

Oracle Metalink was useless — total waste of time — I hate that site now, it’s gone completely into the crapper.

SOLUTION (thanks to David D’Acquisto advice):

1) edit /etc/system as follows:

set shmsys:shminfo_shmmax=12025908428
set shmsys:shminfo_shmmni=100
set shmsys:shminfo_shmseg=10
set semsys:seminfo_semmni=100
set semsys:seminfo_semmns=1024
set shmsys:shminfo_shmmin=1
set max_nprocs=30000
set maxuprc=16384

2) setup project for oracle user (if it’s already setup then just ignore the duplicate error while running projadd command):

projadd -U oracle user.oracle
projmod -s -K "project.max-sem-ids=(priv,100,deny)" user.oracle
projmod -s -K "process.max-sem-nsems=(priv,256,deny)" user.oracle
projmod -s -K "project.max-shm-memory=(priv,12025908428,deny)" user.oracle
projmod -s -K "project.max-shm-ids=(priv,100,deny)" user.oracle
projmod -s -K "process.max-file-descriptor=(priv,65536,deny)" user.oracle

3) bounce the box:

init 6

Here’s how to check for the setting:

## before above changes were applied
##
$ kstat|grep v_proc
        v_proc                          16362
$
 
$ kstat |grep v_maxup
        v_maxup                         16357
        v_maxupttl                      16357
$
 
## after changes/reboot
##
 
$ kstat|grep v_proc
        v_proc                          30000
$
 
$ kstat |grep v_maxup
        v_maxup                         16384
        v_maxupttl                      29995
$

NOTE: the setting above are based on 16gb of RAM if yours is less/more — adjust as per David’s formula.


13 Responses to “11gR2 install fails with “Hard Limit: maximum user processes” error”

  1. 1
    Blogroll Report 12/02/2009 – 19/02/2010 « Coskan’s Approach to Oracle:

    [...] 3-Solution to “Hard Limit: maximum user processes” error in 11GR2 on Solaris Vitaliy Mogilevskiy-11gR2 install fails with “Hard Limit: maximum user processes” error [...]

  2. 2
    Anu:

    Hi Vitaliy,

    While installing oracle 10g on redhat linux i am facing the errors
    i was able to complete installation but,

    1.Enterprise Manager Config failed due to Invalid value null for parameter PORT ……retry configuring databse with enterprise manager later manually by running emca script.

    2.also i see that are no user accounts hr,oe available and also example.dbf is not created.

    Though i was able to open sqlplus and work..i still feel if i go ahead i will face many problems.

    Note: previoulsy on the same laptop i installed and was working on it. But because of some problem i had to reinstall linux and so now oracle too. I am guessing is this anything related to HOSTNAME? bcoz..after i reinstalled linux..i couldn’t find anything in /etc/hosts file..it was empty so i edited with static IP and hostname.

    Please can you help me in solving this issue.

    Thank You,
    Anu

  3. 3
    MVE:

    @Anu
    Most likely yes, your issue is related to incorrect configuration of OS, specifically /etc/hosts.

    Here is a typical run-check I do before install:

    [root@qarac1 mail]# cat /etc/nsswitch.conf | grep hosts
    #hosts:     db files ldap nis dns
    hosts:      files dns
     
     
    [root@qarac1 mail]# hostname
    qarac1.mydomain.com
     
    [root@qarac1 network-scripts]# cat /etc/sysconfig/network
    NETWORKING=yes
    HOSTNAME=qarac1.mydomain.com
     
     
    [root@qarac1 mail]# domainname
    (none)
     
     
    [root@qarac1 mail]# cat /etc/hosts | grep `eval hostname`
    XXX.XXX.XX.XX   qarac1.mydomain.com   qarac1
     
     
    [root@qarac1 mail]# more /etc/oraInst.loc
    /etc/oraInst.loc: No such file or directory

    HTH,
    – Vitaliy

  4. 4
    Anu:

    Hi Vitaliy,
    Thankyou very much for immediate response.

    yes i have checked as u mentioned above.everything was fine except this one

    [root@localhost ~]# cat /etc/hosts | grep `eval hostname`

    returns nothing whereas

    [root@localhost ~]# cat /etc/hosts

    192.168.0.1 localhost.localdomain localhost

    i tried installation again..
    @checking network configuration requirments it is not succeded and says oracle supports installation on systems with DHCP public IP address and i checked the logfile and it says
    checking DetectifDHCPassignedIP …
    …..
    Actual result: java.lang.NullpointerException:Exception/error Occurred

    SO removing static IP and making DHCP…will help? bcoz in windows wheni installed i just did that user verified and installation was fine without any problem and i can work on it.

    Thanks,
    Anu.

  5. 5
    Anu:

    Hi Vitaliy,
    I apologise.
    there was a typing mistake and now

    [root@localhost ~]# cat /etc/hosts | grep `eval hostname`

    192.168.0.1 localhost.localdomain localhost

    works fine now.

    but the installation problem remains same.

    thank u,
    Anu.

  6. 6
    MVE:

    @Anu

    You should put the 127 address back into /etc/hosts — this is mandatory:

    127.0.0.1 localhost.localdomain localhost

    then add the actual IP and your hostname on the second line. Make sure the IP address is resolvable and assigned to your network interface:

    After above changes are done you should bounce your box and verify your network is setup correctly:

    ifconfig -a

    HTH,
    – Vitaliy

  7. 7
    Anu:

    Hi Vitaliy,
    I reinstalled linux and checked commands mentioned by you.
    now everthing looks fine as u said..its shows

    127.0.0.1 localhost.localdomain localhost

    so i will try installing oracle now. i guess if it was this improper OS installation creating the problem, then now Oracle installation should be succesful. i will get back you to you ASAP about the progress.

    thanks,
    Anu.

  8. 8
    Anu:

    Hi Vitaliy,

    Finally i finished installation of oracle 10g on my redhat linux :)
    I tried working with sqlplus, oem,isqlplus…everything works fine like before.

    I realised problem was with misconfiguration of OS.

    Thankyou very much for immediate response,
    Anu

  9. 9
    MVE:

    No problem Anu! Glad to help.

    – Vitaliy

  10. 10
    Install Oracle 11gR2 on Solaris 10 | 달콤 쌉싸래한 인생:

    [...] http://www.dbatoolz.com/t/11gr2-install-fails-hard-limit-maximum-user-processes.html [...]

  11. 11
    Agathian:

    Vitaliy,
    thanks for your article, very nice.

    Can you please let me know what’s the difference between /etc/system and /project settings with respect to Oracle.

    thank you,
    agathian

  12. 12
    Richard:

    Thank you for the article.
    have same problem and tried your workaround.

  13. 13
    jeevan:

    Hi,

    how to calculate Oracle process maximum limit to set based on servers.

Leave a Reply

Vitaliy Mogilevskiy - Solving ORACLE problems since 1996.

View Vitaliy Mogilevskiy's profile on LinkedIn

What you will find here is what works for me day in day out - 24x7x365 - simple ORACLE DBA Tools written using components that are available on every Unix platform with an ORACLE database -- sqlplus and KSH.

Do you have DBA questions? Head over to Ask DBA.

RSS DBA Forums


Recent Comments

  • NJGIN: Thank you for your lucid and accurate instructions!
  • E Konopka: A GREAT help, thank you!
  • Sachin: Thanks! This helped really well.
  • jeevan: Hi, how to calculate Oracle process maximum limit to set based on servers.
  • vivek: I am getting following error SQL*Plus: Release 11.1.0.7.0 – Production on Thu May 22 18:42:01 2014...

Categories

Blogroll


Archives